【题目描述】

对于多项式和给定的a,b,c,d,x,计算f(x)的值,保留到小数点后7位。

【输入】

输入仅一行,包含5个实数,分别是x,及参数a、b、c、d的值,每个数都是绝对值不超过100的双精度浮点数。数与数之间以一个空格分开。

【输出】

输出一个实数,即f(x)的值,保留到小数点后7位。

【输入样例】

2.31 1.2 2 2 3

【输出样例】

33.0838692

解:

#include <iostream>
#include <cstdio>
using namespace std;
int main() {
    double a,b,c,d,x,y;
    cin>>x>>a>>b>>c>>d;
    y = a*x*x*x + b*x*x + c*x + d;
    printf("%.7lf",y);
    return 0;
}

发表评论